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Please note

 Screenshots used in this manual may appear different from those on computer screens used by participants; 
variations in versions of the software and differing operating systems may be in use.

 The World Wide Web is constantly evolving and content and URLs (Universal Resource Locators - website 
addresses) change over time. It is possible that the content located at some of the URLs listed throughout this 
manual may change over time.

 Screenshots and software titles used throughout the manual are from a PC using Windows Vista©. 
 Participants using other operating systems may encounter some differences in screen presentation and layout.

Throughout this module reference may be made to software titles and suppliers of Internet services. 
These references are made purely to illustrate or expound course content. Any such reference does 
not imply any endorsement by the NCTE of a product or company. The reader should be aware that 
typically there are many products and companies providing similar services in areas related to ICT. 
Participants should be as informed as possible before making decisions on purchases of ICT products 
or services. 
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Excel for Teaching Statistics

Duration

5 hours

Objectives
This module aims to enable the participant to:

 be familiar with basic functions of an excel sheet
 incorporate external data 
 convert data to Number format
 draw a charts
 copy an Excel chart into Word or PowerPoint
 perform calculations 
 draw scatter plots 
 draw a line of best fit on a scatter plot
 calculate correlation
 generate a random number in a cell
 set up Pivot tables
 draw a normal curve
 draw a tree diagram
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Excel 2007 in mathematics teaching
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Excel 2007 

Why Excel?

1. A lot of teachers and students are familiar with it.
2. Package is on a lot of school computers.
3. The package enables teachers and students to get instant results.
4. Values can be changed and students see the results of these changes immediately.

Introduction

The following is the Excel 2007interface.

The Ribbon

The Ribbon replaces the menus and toolbars of previous versions of Excel. It uses tabs to allow easy 
access to groups of commands organized by activity.  Once you click on a tab you will see an array of 
buttons organized by group. 

Tabs

Groups

Office Button
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The Home tab contains the Clipboard, Font, Paragraph, Styles and Editing groups. See Appendix A
for a picture of what each tab looks like.

If you like to use the more traditional menu box access there is a small icon of an arrow, inside a 
square, beside each group title. This will reveal the old format of menu dialogue box. 

Office Button
The Office Button, on the top left of the ribbon, groups together  the most frequently used 
commands for what to do with a document - Save, Save As, Print, Close as well as New, Prepare, 
Send and Publish. 

Notice by clicking on each of these tabs a different toolbar appears. So when these notes 
say with the Home tab open, it means that this Home tab is clicked etc.

Spreadsheet

The letters going along the top denote columns and the numbers going down the side 

represent rows.  Note cell B3 contains 34.  Column first followed by row. 

To insert data

With the Home tab, click on the cell you want to enter the data into and type the data. To 

move to the next cell press the tab key on the left of the keyboard or just click on 
the required cell.

With the Home tab open data can be formatted in the usual way, i.e. size of text, colour, 
font etc. changed.

Change Font

Change 
Font colour

Change 
Font size
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To wrap text (Place text on more than one line in a cell)

If the text in a cell is too long to fit in the cell you can wrap it as follows, with the cell in 
question clicked and the Home tab open click the Wrap Text Button. See cell A2 above.

To insert a new worksheet

Click on the Insert Worksheet tab on the bottom of the spreadsheet. Notice that 
by right clicking on a worksheet one can Rename it, Delete it, etc.

To print a worksheet

Click on the Office Button          at the top left hand side of the screen, click Print, choose 
Print and click OK.

To save an Excel File

Click on the Office Button           at the top left hand side of the screen, click Save As, choose 
Excel Workbook, pick the location you wish to save in and click Save.

Equals Formula

For example, if one wants to add or multiply two cells and place the results in another cell. 
Select the cell you want to place the answer in. Place “=” in the Formula Bar. Click on the 
first cell you want to add, place the “+” symbol beside it and click on the second cell you 
want to add. Press Enter on the keyboard. The result will appear in the cell you first selected 
and if you change the value of any of the cells that were the in the formula, the 
corresponding answer will change. 
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Use of a Random Sample from Census at School

For the rest of the lesson it is assumed that teachers are working on a random sample of 
data from Census at School Phase 8.  To access random data from Census at School go to
http://www.censusatschool.ie/get-data/57-random-data-selector. For details of how to 
download data from census at school see Appendix B.

To preserve this original file remember to save under another name or do not save when 
exiting the tutorial.

To hide a column (Notice the difference in Hide and Delete)

Click on the letter at the top of the column that you wish to hide, right click and choose 
Hide. To Unhide a column, click the two column on either side of hidden column/s (You can 
click two columns simultaneously by pressing the Control button on the keyboard, as you 
click the two columns), right click and choose Unhide. 

As there is so much data in the random sample, we would like to hide Columns from P 
onwards and column C. Now unhide column C.

To convert data to Number format (Not always necessary)

(Note if the height, arm length etc. figures in the sample are not in number format and 

hence cannot be used in calculations or graphs.) To convert: drag to select the data, a 
symbol appears beside the data, click on the arrow beside this symbol and select convert to
number.

Select the Height, Foot and Arm columns and convert to Number format.
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To insert data as numbers in the first instance

Select a column or range of cells. With the Home tab open select the arrow beside General
(Middle of the toolbar) and pick Number.

To widen a column

Drag the line on the right of the column to the right.

Widen the J column. 

To draw a chart

Draw a Column chart of the height of the first 4 students. 

Draw a Bar chart of the arm of the first 10 students.

To change the colour of the sections (bars on a bar chart) on the chart

Right click on the bars of the chart and choose Format Data Series. Click the Full tab. Click 
Solid Fill and pick the colour of your choice.
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To change the colour of just one section of a chart

Double click on the section you wish to change, right click and choose Format Data Point. 
Change the options as required: for example, Fill.

To change the colour of the Chart Area

Right click on the blank area of the chart away from the sections. Choose Format Chart 
Area. With the Fill tab open choose Solid Fill, etc. Click Close.

To Change the colour of the Plot Area

Right click in a blank area just beside the sections. Choose Format Plot Area. With the Fill 
tab open choose Solid Fill, etc. Click Close.

To change Chart Walls, Chart Floor, etc.. of 3D diagrams

With the chart selected open the Layout tab and, for example, if it is a 3D diagram follow 
the Chart Floor arrow and More Floor Options. Choose Fill, Solid Fill, pick a colour and 
move the percentage transparency you require. Click Close.

Draw a 3D Column chart of the breath of the first 8 student and insert an orange floor.
Note: make sure the data is in number format.



To make a chart using more than one set of 
results

Select the data and draw the chart in the usual way.

Draw a Bar chart of the height, foot and arm 
pattern.

To draw a chart using a set of data tha
example the results of students 3, 5 and 7 in the diagram below

Press Control on the keyboard and select the data required. 

Draw a chart of the height and arm

To draw a Pie Chart and show labels

Select the cells concerned. With the 
Right click the chart and choose 
Labels.

Draw a Pie chart of cells L18 to L21 and adjus

To Draw a Histogram with even class intervals

(A special tool called Analysis Toolpak has to be installed an
done go to Appendix C at the end of this document.)

Type a table like the one opposite, with the actual values in the first 
columns and the interval extremes on the right. Check the intervals 
are equal. With the Data tab open, click 
the screen. Pick Histogram and OK
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To make a chart using more than one set of consecutive 

the data and draw the chart in the usual way.

height, foot and arm of the first 5 students. See if there is any 

using a set of data that is not immediately under the headings 
of students 3, 5 and 7 in the diagram below.

on the keyboard and select the data required. 

arm of students 3, 5 and 7.

and show labels

cells concerned. With the Insert tab open click Pie and a list of options appears. 
the chart and choose Add Data Labels. Right click again and choose Format Data 

18 to L21 and adjust some of the fills etc.

To Draw a Histogram with even class intervals and ungrouped data 

(A special tool called Analysis Toolpak has to be installed and to see how this is 
Appendix C at the end of this document.)

Type a table like the one opposite, with the actual values in the first 
columns and the interval extremes on the right. Check the intervals 

open, click Data Analysis on the right of 
OK.  

of the first 5 students. See if there is any 

mmediately under the headings For 

and a list of options appears. 
Format Data 



A new dialogue box appears.

For the Inputs Range select the values and for the 
Click Chart Output.

Click OK. Notice it appears on a new worksheet.

To close the gaps between the bars of the Histogram

1. Right click on the chart and 
Series. 

2. A new dialogue box appears. With the 
Options tab open set the 
click  Close.

Draw a Histogram for howlong for 
the data set.

To copy an Excel chart into Word or

Click on the graph, right click and choose 

Open either Word or PowerPoint and copy a chart you produced into it.

To calculate the Maximum, Minimum or Average (Mean) 
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select the values and for the Bin range select the interval extremes.

. Notice it appears on a new worksheet.

To close the gaps between the bars of the Histogram

on the chart and choose Format Data 

A new dialogue box appears. With the Series 
open set the Gap Width to 0% and 

for all the students in 

To copy an Excel chart into Word or PowerPoint

and choose Copy. Open Word or PowerPoint and 

Open either Word or PowerPoint and copy a chart you produced into it.

, Minimum or Average (Mean) of a set of data

select the interval extremes.

and click Paste. 
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Select the set of data, right click the bar at the bottom of the screen and make sure 
Maximum (or Minimum or Average) is selected. These values will now appear on this bar.

To calculate the Maximum, Minimum, Median or Average of a sample of data and insert it 
in a cell

Click on the cell you want to put the value into. Click on the Insert Function button at 
the top of the worksheet and change the option “or select a category:” to “All”.  

Pick either Max, Min, Median or Average, from the options offered.

In cell B23 type the word ‘Maximum’ and then click into cell C23 and insert the maximum of 
the cells C2 to C21. In row 24 repeat for median.

To Fill cells with the same type of formula, etc. 

Select the cell that contains the formula you want to fill the other cells with, drag the box on 
the bottom right of this cell across or down the other cells that you want to fill.

Alternatively select the cell with the formula and those that you want filled. With the Home 
tab open, select the arrow beside Fill on the right hand side of the toolbar and pick the 
required direction.

By dragging the format of cell C23, find the maximum of columns D, E, F and G.

By dragging the format of cell C24, find the medians of columns D, E, F and G.
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In cell C25, D25, E25, F25 and G25 place the minimum values of columns C, D, E, F and G 
respectively. Repeat for the average in row 26.

To count the number of entries in a selection of cells

Select the cell you want to put the result in. Go to the Insert Function button and pick
CountA as the function, select the cells you want to count.

Using the CountA function, place in cell K23 the number of entries in the travel column. 
Remove one of these entries and see the figure in cell K23 change.

To Count the Number of people, who travel by each mode of transport

Click on the cell you want to put the result into. Go to the Insert Function button and 
choose COUNTIF. A new window appears on the screen. Choose your cell range and the 
criteria.

For example, if you want to discover the number of people in the data set who travel by bus
and place this figure in K24, the cell range would be K2:K21 and the criteria would be “bus”. 
Change one of the non bus cells to bus and see what happens. Do the same in cell K25 and 
K26, K27 and K28 for “walk”, “rail”, ”other” and “car”.

Draw a pie chart of these figures.
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To calculate Correlation

1. Click in the cell you want to place the correlation value in.

2. Go to the Insert Function button and change the option “or select a category:” to 
“All”.  Choose CORREL and a new window appears.

3. Click beside Array 1 on this new window and then highlight the first column of data that you 
want to use for the correlation.

4. Click beside Array 2 on the window and then highlight the second column that you want to 
use for the correlation.

5. Click OK.

Find the correlation between the arm and foot columns.

To draw a Scatter Plot

1. Highlight the two rows of data that you want to use for the scatter plot.

2. With the Insert tab open choose Scatter. Pick the first type of scatter plot offered.

Draw a scatter plot of the arm and foot columns.
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To draw the Line of Best Fit on a Scatter Plot

1. Right click on one of the points on the scatter plot and choose Add Trendline.

2. In the Trendline Options choose Linear. Click Close.

3. If you wish to show the equation of this line, highlight the line and right click. Choose 
Format Trendline.

4. With the Trendline Options tab open, at the bottom of the screen click Display Equation on 
chart. Click Close.

It is recommended in this training module that participants go to Module 1 page 20 and complete the 
activities on how to draw a Scatter Plot and Line of Best Fit and calculate Correlation using 
GeoGebra.

To find Quartiles of a data set

Click on the cell you want to put the quartile value into. Then click on the Insert Function 

button at the top of the worksheet and pick Quartile from the selection of functions. 
A new window appears. Click in the space beside Array and select the data set (or type in 
the cell range for example F2:F21) of which you want to find the quartile. If it is the first 
quartile you require type 1 beside Quart and click OK. If it is the third quartile you require 
type 3 beside Quart and click OK.

Find the first and third quartile of the arm in the data set.

To find the Interquartile Range

To find the interquartile range you need to calculate the difference between the value of 
the third quartile and the first quartile. If the value for the first quartile for column L is in cell 
L23 and the value for the third quartile is in cell L24 and you want the interquartile range 

value to be placed in cell L25. Click in cell L25, click beside the Insert Function button
and type in = E24-E23 and press Enter. The interquartile range value will appear in cell L25.

Find the interquartile range of the column N.
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To find the Standard deviation of a data set

Click on the cell you want to put the standard deviation value into. Click on the Insert 

Function button at the top of the worksheet and pick STDEVP from the selection of 
functions. A new window appears. Click in the space beside Number1 and select the data 
set (or type in the cell range for example F2:F21) for which you want to find the standard 
deviation. Click OK.

Find the standard deviation of some of the sets of data.

To sort a set of data

Select the data concerned. With Data tab open, select Sort and a new window appears. 
(Sort is also available on the Home tab.) Click the Expand the selection button, click the 
arrow beside Sort by, pick your criteria and click OK. Note when you click the Expand the 
selection it means each person’s records in the sample stays with that person.

Sort the data by Age.

To filter data in a column

(Filtering data enables you to view a subset of the data.)

Select the column with the items that you want to filter. With the Data tab open, click the 
Funnel shape on the toolbar, follow the little arrow that has appeared on the top of the row
and pick the criteria you require.

To get all the records back, follow the arrow on the top row and select (Select All).

Filter column J in the worksheet Data, so that only those students who have usefullanguage 
as french. 
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To filter more than one column

Select all the columns to be filtered and following the normal filtering procedure for each 
column.

Filter those records that are age 13 and have a foot size of 23, 24, 25 and 27.

To freeze the top row in a spreadsheet

With the View tab open click on the top row. Go to arrow beside Freeze Panes and pick 
Freeze Top Row.

Freeze the top row in the worksheet Data.

To generate a random number in a cell

Click on the cell you want to place the random number. Next, click on the Insert Function 

button and choose RANDBETWEEN. Insert the Bottom and Top values allowed. Click 
OK.

By right clicking Column B, insert a new column and in cell B1 insert a random number 
between 1 and 6. Now fill this column to generate a random number for each student. Keep 
refilling and you will notice it is filled with different numbers each time.

To enable those cells to be coloured in which fulfil a certain criteria

With the Home tab open select those cells that you want judged; go to Conditional 
Formatting and pick the criteria. Pick a rule and a condition. For example to colour those 
cells in the Language column that is greater than 2 in green. First make sure the numbers 
are stored in Number Format, then select the Language column and with the Home tab
open, click the Conditional Formatting button, pick Highlight Cell Rules, and Greater Than
and  in the for Greater Than box insert 2 and for with pick ‘Green Fill with Dark Green Text’.

Fill those cells in the Age column that are greater than or equal to 13 in a pink fill and in a 
brown text.
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Data Validation

This is where you restrict the data that can be entered in a cell or cells to ones you have 
decided beforehand. Select the cell or cells that you want to validate. With the Data tab
open in the Data Tools section, click the arrow beside Data Validation and pick Data 
Validation.  

With the Settings tab open in the new window, for Allow pick Whole Numbers and give a 
Maximum and a Minimum and then if you type in a number in that cell beyond those 
ranges you will get an error message. If you want to set it so that a cell or group of cells will 
only accept the days of the week, after you picked Data Validation, pick List and for Source
type in the each day of the week followed by a “,”.

Set up any 4 cells of your choice so that the only data that can be inputted into these cells 
are male and female. 

Lock or Protect cells (Prevent people using the worksheet changing the contents of certain 
cells.)

1. Select the entire worksheet by clicking the Select All button (the gray rectangle 

directly above the row number for row 1 and to the left of column letter A). 

2. With the Home tab open, click the arrow symbol beside Font

3. A new window appears click the Protection tab on this window and then clear the 

Locked check box. This unlocks all the cells on the worksheet

4. Select just the cells you want to lock and repeat step 2 and 3, but this time select 

the Locked check box. 

5. On the Review menu, point to Protection, click Protect Sheet, and then click OK.
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Absolute Reference

If for example cell B7 is the Total and cell B2=546 and in cell 
C2 you want to insert an equation to represent the 
percentage of the total sales that Area 1 had. 

So you want to place the equation B2/B7*100 in cell C2, 

with cell C2 selected go to the Insert Function button
and place = B2/B7*100 and you get the value 26.1 (Using 1 decimal point), which is correct.

Now if you try to fill the cells C3:C6, with the same formula a problem occurs. The formula 
that C3 is filled with is B3/B8*100, not B3/B7*100, which you wanted. To prevent this 
happening, when entering cell B7 in the equation for C2, you must put it in as $B$7. This 
means B7 becomes an Absolute Reference and when the fill tool is used it remains as B7.

To Print a worksheet with Gridlines

With the Page Layout tab open, click Gridlines and the Print button.

To view a page in Landscape

With the Page Layout tab open, select the arrow beside Orientation and pick Landscape.

To add a background to an Excel worksheet

With Page Layout tab open, click Background and go to the folder where you have a picture 
suitable for backgrounds stored. 

Good free backgrounds are available at:

http://office.microsoft.com/en-gb/clipart/default.aspx
http://www.grsites.com/textures/
http://www.aaabackgrounds.com/textures/cloth/index.html

Note that with some websites you should first save the file you want to download to your 
computer and scan it for viruses before opening it.



To find the frequency of a set of data

Create a vertical range of cells containing the upper bands into which you wish t
your data. Select the cells you want the frequencies to go into. Go t

button and choose Frequency
want to find the frequency of and for the 
Control, Shift and Enter keys simultaneously on the keyboard instead of 

Design a frequency table for the Concentration times on the data set.

To set up Pivot tables

1. Type in the data as it appears in the opposite table. 

2. Sort the data according to Male and Female. 

3. Click on a blank cell away from the inserted data.

4. With the Insert tab open go to 

5. Select the cells A1:B7. (Make sure to include the titles.)
Existing worksheet and OK

6. Click Gender in the Pivot Table
of the genders.

7. Click Mark in the Pivot Table Field List

You now get a break down of the totals of all the marks.

In the Pivot Field List go to Values
Settings. Choose, for example, Average
all the marks.

22

To find the frequency of a set of data

Create a vertical range of cells containing the upper bands into which you wish t
lls you want the frequencies to go into. Go t the Insert Function 

Frequency. For the Data Array, select the set of data that you 
want to find the frequency of and for the Bin Array, select the set of upper bands. 

keys simultaneously on the keyboard instead of OK.

Design a frequency table for the Concentration times on the data set.

Type in the data as it appears in the opposite table. 

Sort the data according to Male and Female. 

on a blank cell away from the inserted data.

open go to Pivot Table and choose Pivot Table.

(Make sure to include the titles.) Click
OK.

Pivot Table Field List. You now get a list 

Pivot Table Field List. 

You now get a break down of the totals of all the marks.

Values and click on the one that is visible. Choose Value Field 
Average and click OK. You now get a break down of the averages of 

Create a vertical range of cells containing the upper bands into which you wish to group 
Insert Function 

elect the set of data that you 
select the set of upper bands. Press the 

Value Field 
. You now get a break down of the averages of 
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Now filter the Row Labels (Follow the arrow beside Row Labels.) so only the average of the 
Females is showing. Then filter the row labels so only the averages of the Males are showing. 

Find the Standard Deviation of each gender and of the total using your Pivot Table.

To draw the normal curve

The goal is to create a normal distribution graph with a specified mean and standard 
deviation. Start by entering those values in some cells in a worksheet.

The example used to illustrate the process plots a graph with a mean of 10 and a 
standard deviation of 2. Enter those values in cells F1 and H1. 

Start by setting up the x-values for a standard normal curve. 

In A2, enter the number -4.

With the Home tab open go to Fill and choose Series.

Set up the resulting dialog box below. 
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Use a Step value of 0.25 and a Stop value of 4.
However, if you want more data points, use a 
smaller number, such as 0.1 for the Step value. 

Next, in B2, enter the formula =A2*$H$1+$F$1.
This converts the standard normal distribution to 
the distribution of interest i.e. z values to x –

values . (Since )
x

z x z
  




   

In C2, enter the formula =NORMDIST 
(B2,$F$1,$H$1,FALSE).
This provides y-values for the distribution of 
interest.

Copy B2:C2 down to cover all the rows that 
contain data in column A.
The result should look like the spreadsheet at the side of this page.

Select all of the values in columns B and C. With the Insert tab open go to Scatter and 
choose Scatter with Smooth Lines.

The result should be as on 
the left. 
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Change the mean and standard deviation values and see the curve change shape.

To draw Tree Diagrams (Same instructions apply to Word 2007)

With the Insert tab open choose Smart Art and choose Hierarchy on the left hand side of the 
table and choose Horizontal as shown on the chart below.

1. Click OK.

2. Type the text you require into each of the boxes provided.
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3. To add another shape in the series already there.

Click on the shape before or after which you want to add the new shape and with the Design 
tab clicked, click on the arrow beside Add Shape on the right hand side of the screen. Click
either Add shape After or Add Shape Before. A new box should appear

4. To add another series of shapes.
Click on a shape to the right of which you wish to add the new series of shapes. With the 
Design tab clicked, click Add Shape on the right hand side of the screen. Click Add shape 
below.
To add colour to an individual shape. Highlight the shape, right click and choose Format
shape. Click on the Fill tab and Solid Fill. Follow the arrow beside Color to get the colour of 
your choice. Click Close.

Draw a Tree Diagram that represents all the possible outcomes of tossing a coin 3 times
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Help

Note: The Microsoft Office Excel Help button   on the top right hand side of the excel page 
leads to Help.

Useful web pages

http://www.teach-ict.net/software/excel/excel.htm

http://office.microsoft.com/en-
us/excel/FX100646951033.aspx?CTT=96&Origin=CL100570551033

For Short Cut keys in Excel go to 

http://office.microsoft.com/en-gb/excel/HP052037811033.aspx
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Appendix A

The Home Tab

The Insert Tab

The Page Layout Tab

The Formulas Tab

The Data Tab



29

The Review Tab

The View Tab

The Developer Tab
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Appendix B

How to access data from www.censusatschool.ie.

Go to http://www.censusatschool.ie/get-data/57-random-data-selector.  

Click on the Access Random Data Selector link. A new page appears.

Click on the link Click here to access the Random Data Selector.
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Scroll down the next page that appears and insert the required details.

Click Submit.

Pick the country you wish to data to come from, for example, United Kingdom.

For the Phase pick, for example, Phase 8 2007-2008 and click Submit.

Click Secondary and click Submit.
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Click Sample Size and Submit.

Click Get Data. Save in a location of your choice and with a file name of your choice.
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To preserve this original file remember to save under another name or do not save when 
exiting the tutorial.



Appendix C

How to install the Analysis Toolpak tool

Go to the Microsoft symbol at the top of the screen and 
middle line of this box.

A new dialogue box appears. Click Add

Click Analysis ToolPak in the Inactive Applications Add
sure Excel Add-ins is visible in the drop down menu beside 
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How to install the Analysis Toolpak tool

to the Microsoft symbol at the top of the screen and click Excel Options on the bottom 

Click Add-Ins on this box.

Inactive Applications Add-ins section of this window. Making 
is visible in the drop down menu beside Manage, click Go.

on the bottom 

section of this window. Making 



35

A new dialogue box appears.

Click the Analysis ToolPak box and click OK.

Now when the Data tab is open the Data Analysis tool will be displayed.


